Need Help, Nava Won't Power Up (2024)

  • Post Reply
    • Print view

5 posts

Page 1 of 1

  • decoder303

    Posts 89
    Joined: May 18th, '16, 19:33

    is the sequencer working? are any LEDs working, the display? if not, you might want to start troubleshooting the sequencer, since you need it to trigger the voices.

    • Quote
  • talos

    Posts 15
    Joined: May 2nd, '16, 03:18

    decoder303 wrote:is the sequencer working? are any LEDs working, the display? if not, you might want to start troubleshooting the sequencer, since you need it to trigger the voices.

    Nothing turns on. No Display, no led's, nothing. I can hear something cooking when I plug it in though haha, but that just tells me voltage is going through the IO board. How would you suggest I start troubleshooting the sequencer? Im curious to see how I can just get the display to just turn on.

    I checked the voltage on the sequencer where it would say 5V and I'm getting like .6 instead. Something is coming through, but not enough of course...

    • Quote
  • housedet@comcast.net

    Posts 85
    Joined: Mar 22nd, '16, 10:30

    I'm not a pro at this stuff, yet, but it appears like you might be having the same issue I had and still haven't figured it out yet. First off, I wouldn't add anymore power to the board until you make sure you don't have the same issue I do. I have a 5v to ground short. In other words, without any power to my board, I set my multimeter (MM) to check continuity, and no matter which 5 volt point I set one probe on and the other on any ground on the board, I hear the loud beep which means I have a direct connection. Lets say I take one probe and place it on the 8 pin connector of the sequencer that says 5v, then take the the other probe and place it anywhere that's supposed to be ground, even in the main section, and I have a connection. I've been at this for over 40 hours on and off of course and got so fed up that I purchased a second Nava which I started yesterday and I'm going to check to see where this problem might be coming from by checking for the continuity problem after every section I solder up. My board also looks perfect, NO solder bridges. I've already built 2 Yocto's and didn't have a short out issue. Also, not that this has anything to do with your problem, (if it's the 5 v to ground short problem) it appears that you used regular wire for the 6 pin connector in the Master section instead of insulated Audio cable. I made that error on my first Yocto and it sounded awful, not that you'll be able to hear it yet until you can figure out your Sequencer issue. To be safe, I would unplug all connections to the IO board and begin testing to see if you are in fact dealing with the same irritating problem I am, at least without power added to the mix you won't run the chance of frying your components. First start out by placing one probe on the first pin of the 8 pic connector (ground) then touch the 8th pic (5 volt) and if you hear the dreaded beep, if your MM does beep when when checking continuity, you do have a short. I pray for your sake and sanity that you don't. Good luck!

    • Quote
  • Kazper

    Posts 62
    Joined: Feb 20th, '16, 20:06

    First, there is some instructions and parts that didn't work as espectected. Make sure you followed the start up procedure.

    You should look over all the pcb, make sure no chips are backwards etc.

    Check power
    Check the master section
    Check each drum sound, trigger each individually

    • Quote
    • Post Reply
      • Print view

    5 posts

    Page 1 of 1

    Return to “Nava Hardware”

    • Jump to
      • Sys-100M Series
      • ↳ M-191X replica case
      • Nava TR-909 clone
      • ↳ Nava Hardware
      • ↳ Nava Software
      • ↳ Nava Mods
      • Yocto TR-808 clone
      • ↳ Yocto²
      • ↳ Yocto² Hardware
      • ↳ Yocto² Software
      • ↳ Yocto² Mods
      • ↳ Yocto v1.0
      • ↳ Yocto v1.0 Hardware
      • ↳ Yocto v1.0 Mods
      • ↳ Yocto v1.0 Software
      • Marketplace
      • ↳ Black Market
      • Archive
      • ↳ E-licktronic meets Arduino
      • ↳ Projects

    Powered by phpBB® Forum Software © phpBB Limited

    Privacy|Terms

    Need Help, Nava Won't Power Up (2024)
    Top Articles
    Latest Posts
    Article information

    Author: Amb. Frankie Simonis

    Last Updated:

    Views: 6340

    Rating: 4.6 / 5 (76 voted)

    Reviews: 83% of readers found this page helpful

    Author information

    Name: Amb. Frankie Simonis

    Birthday: 1998-02-19

    Address: 64841 Delmar Isle, North Wiley, OR 74073

    Phone: +17844167847676

    Job: Forward IT Agent

    Hobby: LARPing, Kitesurfing, Sewing, Digital arts, Sand art, Gardening, Dance

    Introduction: My name is Amb. Frankie Simonis, I am a hilarious, enchanting, energetic, cooperative, innocent, cute, joyous person who loves writing and wants to share my knowledge and understanding with you.